Problem with group editing of components

I edit several components that have text at the same time, e.g. buttons or labels. I change e.g. size, color in them. Then in each label I change the text separately. The problem is that when I change the text in e.g. label 1, the text changes in label 2. I don’t know if my post is understandable because I translate in Google translator. I mean group editing of several of the same elements.

I believe this behaviour is by design. In group editing one might expect that changing the text would change it for all the selected elements, just as with the other properties like colour/font size?

You not understand. I don’t change the text in groups. First, I change the appearance of elements in groups and then the text one by one. This is not working properly. After group editing, item IDs probably do mix.

Make the test:

  • create several text labels
  • select all labels
  • change the font and eg the background color in groups
  • disable group editing
  • try to change the text in each label separately

Tested and working OK for me here, once group is deselected, editing of text labels is individual. This on Linux/Firefox

Something is wrong with Windows 10 Home, Chrome. I tested it on Firefox and it is the same. It’s also that he types the text and it doesn’t change in the view. This only happens after the group edition.

works fine for me on Windows 10 Home, Google Chrome Version 79.0.3945.79 (Offizieller Build) (64-Bit)


Trying to push the limits! Snippets, Tutorials and Extensions from Pura Vida Apps by Taifun.

1 Like

I already know when the problem is. If right after entering the text you click on the phone view. Enter the text and click on the next label in the phone view.

? phone view - do you mean in the designer ?

Can you be more specific, I tried the above but still no problem for me....

Yes designer.

  • add 3 text labels
  • select all 3 labels and change font and size (group editing mode)
  • uncheck the labels
  • click on label 1
  • enter text, do not press enter, click on the phone graphics (designer)

For me, the text does not update in the phone view. There is new text in the text box, and old text in the phone view. The problem is only in labels that were previously edited in groups. If the labels were not edited in groups, there is no problem.

Maybe I just won’t click in the phone view but after entering the text I will click next to the text field or press enter. The only strange thing is that for labels that were not edited in groups, there is no difference where I click.

OK, I can replicate that now, even got it to break with a label not selected for group edit (first time)
Not sure why users would not press enter after editing a text, but will assign to MIT for their bug list.

I do this out of habit, because enter is for me the transition to a new line. Probably the reason is also the speed of project creation :upside_down_face:

I’ve been creating in AppInventor for over a year and I’ve always done that. Only now I noticed this error, so it may be related to the addition of the group editing option.

For me it's working fine.

(only if I change the text in the designer in Label1 and then click on Label2 will the new text be assigned to Label2)

You can see in the movie that it doesn’t work well. You have entered text in label1 and changed the text in label2. After changing the text, click in the phone field, not around to it.

The same result, works fine.

If it works well, why do you have text from label 1 in label 2 in your video? Sometimes the text mixes between labels, sometimes the text doesn’t update. It works differently but certainly not well.

Yes, if you change a label text and then click on another label, some things go wrong.
If you know what the problem is, so why should you click on the next label necessarily?

For me it is to quickly move on to editing the next label. After that, I have a problem even when I do not click the next label, but any element on the phone view. And the same problem is also with buttons and other elements that have text.
I don’t use the mouse, only the laptop touchpad. When there are many labels, each click increases programming time. There is another problem, the list of items scrolls after editing the item. Then you have to search again in the long list of items to edit. It’s terribly bothersome. I remember that a year ago when I started playing in the appinventor this problem was not.

Why don’t you create the labels, buttons etc. programmatically, e.g.:!searchin/mitappinventortest/100$20labels|sort:date/mitappinventortest/kE1-JPi2sQA/56had43ACwAJ!searchin/mitappinventortest/create$20KIO4|sort:date/mitappinventortest/zkha9QCIHWQ/axbcZQ-kBQAJ

Can I create this layout programmatically? Labels mixed with text fields of different sizes and different spacing?

Do programmers MIT see what we’re reporting here? I see there were two AppInventor updates and the group edit error still occurs. We can discuss here how and where to click, but it is an error and can not be denied. However, it is MIT programmers who should verify that it can be improved. Well, unless it is impossible or it is too difficult?