Problem with Anke's "Install apk from ASD extension"

But has this anything to do with this error?


There is a lot of difference between these two lines:



request.setDestinationInExternalPublicDir(dir, name);

The first one saves files in ASD while other saves file in external storage.
I got the solution from the SO link shared by you.

1 Like

@vknow360 Thank's, I'll check that later ...

1 Like

Looks like the same problem with Deep_Host's extension. It has an Open_Direct_file block that gives the same error.

For now, i solved the install problem with calling chrome and download with that and install after download, but waiting for some working extension. So far neither is working. I even tried KIO4_istall too.

By the way, if someone knows what preferences in activitystarter and permissions i have to set to be able to install from the app, that is also acceptable i think.

did you already try the install extension by @Juan_Antonio?

the activity starter solution, which was discussed here unfortunately does not work anymore for newer Android versions...


Trying to push the limits! Snippets, Tutorials and Extensions from Pura Vida Apps by Taifun.

Even if it works, it work from SDcard, that not have avery device. I need one that work from internal drive. From internal(default download dir)it gives the same error.

the extension from @Juan_Antonio should work from the internal (emulated) sdcard... as you said, it would not make much sense to offer an exension, which works only for external (removable) sdcards...


Ok. So, how can i create an emulated SDcard?

I think i got it. I give it a try.

No succes. Even i do it something wrong or it doesnt work on Internal.
By the way, it is an Android 9 device.

unfortunately without seeing your relevant blocks and without knowing what you are doing exactly nobody will be able to help...

I have now created an extension that can also be used to download and install an APK with AI2 (using AndroidX libs). It should work with all versions of Android. The given download link (GoogleDrive) downloads an almost empty APK (only one button, 3.2 MB). But you can also set your own link to your app (APK).

So check that on your devices with different Android versions, especially Android 10 and 11.

It is working on android 8 and 9.
I can only test on next week for android 10.
Waiting for the aix download link.
Thank you Anke!

If i am right the emulated SDcard dir looks like this:
I tried to install from this with KIO4. Doesnt work.
By the way DeepHost's custom download also save the file to emaulated dir. I checked it. It gives the same error with that too.
But seem Anke solved the problem. I'm just waiting for the aix download link.

I would like a few successful tests with Android 10 and or 11 beforehand to see whether it works on different devices with Android 10 or 11. So maybe someone will be nice enough to check it out.
It works on my Pixel 2 XL (Android 11 beta).

1 Like

yes, but probably the extension uses relative paths?

the recommendation is to read its documentation as well as to check examples how the extension is working, for example here

unfortunately you still did not provide a screenshot of your relevant blocks

Tested on Android 10 works fine.
I've seen you published the aix too.
Tested it now. Works fine.
Thank you.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.