Problem to import .aia file

Here some problem to import .aia file

You are giving very little information. What aia-file? Where is it coming from? Is it made with App Inventor? etc, etc.

1 Like

yes it is made from MIT app inventor... its a little part of one app, i want to add this in my app.. so i am importing this file but it showing this error mssagr

unable to load project with form version 37 ( maximum known version is 27 )

Are you using the online version of App Inventor? Are you trying to import an aia-file in another project?

To be 100% clear fazal, you are using
Import project (.aia) from my computer

Can you attach the .aia file to this Topic?

this looks like you are trying to import a project, which is coming from somewhere else, for example another App Inventor distribution...


Trying to push the limits! Snippets, Tutorials and Extensions from Pura Vida Apps by Taifun.

I thought a new project will be generated upon completion of importation an aia file.
Am I getting this wrong or now that we can merge the contents of different projects through importing ?

No, you can not do that. That's why i was asking what the user is trying to do. It was not clear if he wants to merge projects by importing the aia in an existing project. You can import an aia as an asset but you can not merge projects this way.

Upcoming in nb184:
for Designer components, already for block-level .png downloads.

1 Like

Hey, I also have the same problem but with a download of another website. I tried it with one of the projects in there before and it worked, but now it doesn't. When I put the aia download, it says it needs to be an aia when it already is, can someone help, please?

Brick_Breaker.aia (138.8 KB)

According to Unchive
that is not an .aia file.

Where did you get it?

There is, I beleive, an aia file inside the zip (renamed as an aia)

This was inside, only design no code

Chapter8Source.aia (66.4 KB)

got it off a website for class
here is the link

Yes, exactly what i needed, Thank you very much :smiley: