Problem: download file from Google Drive

Hi! I have a problem with my app.
I have created an app with different functions for my work, one of them is to download some images (schematic plans).
Basically an AI2 screen is a simple list, with the names of the images as elements.
When you click on an item in the list, the image is downloaded from a public folder of Google Drive, and automatically opens with the gallery app.
So far so good, I built the app correctly, and for about 6 months it worked perfectly.
The problem arose a few months ago, when clicking on the items in the list no longer started the download, as if Google Drive had changed the url of the files.
I tried to verify the urls by pasting them in the browser, and the image opens correctly (the addresses are correct).

I tried to insert a different url to exclude a block error, and using a url of a random image on the web it works, and the download starts successfully!
So the error is in Google Drive. I tried to upload files to Dropbox, Mega, but got the same error.

I also tried to modify random parts of the drive url, but the best result I was able to get was to start the download, but the downloaded image was "empty", 20kb instead of 3mb

This is the link of an image in my public folder (I cannot send schematic plan links).

This is the url I entered in the block editor to download it (if you copy/paste in the browser, the download starts)
https://drive.google.com/uc?export=download&id=19eWzxax5An4LdVAk3q4vwnkgD04UUcgO

Where am I wrong?

What android version / api are you working with on your testing device. If +10 / +29 then this is the most likely reason that you can no longer save to the directories you are specifying. You will have to save into your ASD (application specific directory). It is not a google drive problem.

Search the forum for how to do this....

Hi, thanks for the very quick reply.
I have tried the app on different devices, from android 5 to androd 10, and the problem is the same.
It is definitely not a problem of saving in a certain folder, because I repeat, if instead of the url of the google drive file, I insert a url of an image from the web (https://www.legadelcane.org/wp-content/uploads/popup-adozione-distanza-2020.png) the app works perfectly, and downloads the image of the folder I indicated.

Could it be an issue with the extended webviewer extension ? You don't need it, just use the web component with a GET.

This is working for me:

image

See here: