Problem creating and sharing pdf file

Good morning

I'm having problems creating a pdf file using an extension and sharing it using the share component. All I keep getting is file not found. Please help

If working with android 10 +, make sure you use the "10" blocks in the extension

I have, I've looked at the forum and this seems to be a common issue, I tried your aia file and that doesn't work either.

Not according to your blocks



In companion, use Do It to debug your blocks (especially your file paths)

I've already tried it, still says cannot find file

Is the file in

  1. the ASD ?
  2. /Documents ?

Do you need to copy it to /Documents to Share it ?

If I remember things correctly, you will need to delete any previous file created in /Documents before copying over a new one, for it to be readable.

The file is in ASD but need to copy it or move it to Documents to be able to share it. That's where I'm struggling. I'm not sure how best to go about it.

If you could show me how best to save it so I can share it using share component I'd appreciate it. Must be compatible with latest version of android. Any help would be greatly appreciated

On Android 12 I have not problem sharing a file in the ASD by gmail

Gmail/Sharing cannot find a file in /storage/emulated/0/Documents to share.

Therefore, share from the ASD, this is read/write for your app

Im not sure how to do that. Please can you show me. Sorry for being a pain


1 Like

Thank you, I'll try it

Also, based on what has just been resolved here, for your /Documents folder, try the full path

1 Like

Thank you it worked brilliant