Post file problems

Hi all,

I have a problem with the postFile block inside a web object and really could use some help :slight_smile:

All I want to do is upload a simple .txt file to a API. With Postman it works perfectly.

As you can see i get response code 200, unfortunately I could not get same result with app inventor.
I tried a lot of different options, none of them worked.. This example is the one I trust the most.

Does anyone know what I forget here?
Thanks in advanced!

What is the error?

Do you need to give the file a name after &file=

@TIMAI2 @Alpha2020 Thanks for quick response!

I just figured it out after almost 4 days.

I had to change Content-type application/json to application/x-www-form-urlencoded
and changed from sending a file to reading a file and send it as data

Thanks for willing to help :slight_smile:

the web component does not support multipart/formdata , i.e. a mixture of binary data and text


Trying to push the limits! Snippets, Tutorials and Extensions from Pura Vida Apps by icon24 Taifun.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.