Please Help, Making My Own Builder Through App Inventor

According to the PM you sent me on telegram
You didn't clone in the location you know
You have just opened Git bash from start menu while cloning which is wrong
So try to open the folder you often visit and right click and click on git bash and then clone
This should work fine as I did it last week and everything worked fine

Clone again in any other drive
Don't do it in C drive and see what happens
Also you can see my guide

1 Like

Good guide.

Thanks :grinning:.......

Local build server success

I followed all the steps correctly and gave ant command to build app inventor in localhost.

C:\Users\rubyd\appinventor-sources\appinventor\build.xml:21: The following error occurred while executing this line:
C:\Users\rubyd\appinventor-sources\appinventor\buildserver\build.xml:189: Java returned: 1

Total time: 40 seconds

You need buildserver for making apk files
To run the main server you need to run the ant command
Before building the main server you have to update the git submodule

updated before.

When ANT command given

Build Failed :frowning:

Why don't you use any other drive?

Okay, I will try.

The issue has nothing to do with which drive the build is running on (I always run it in C: on Windows). The issue here is likely that you're not using the correct version of Java, as the error messages shown happen when the running JRE is newer than Java 8.


You can download JDK 8 from here:

1 Like

I am using the latest JDK.

Can you suggest me any alternative way?
As I am using the latest JDK.

you should use Java 8
from the Introduction GitHub - mit-cml/appinventor-sources: MIT App Inventor Public Open Source

We provide this code for reference and for experienced people who wish to operate their own App Inventor instance and/or contribute to the project.

This code is tested and known to work with Java 8.


Build was successful

Now I am seeing these but I have installed python 3.9.0 properly @ewpatton @Taifun

I tried again

If it helps, just successfully built App Inventor from sources on a fairly new installation of Xubuntu 20.04. Here is the command list, with some outputs (##) and browser commands( ##in browser#)

sudo apt install curl
curl -O
tar -xzf /google-cloud-sdk-318.0.0-linux-x86_64.tar.gz
./google-cloud-sdk/bin/gcloud init
sudo apt install libc6:i386 zlib1g:i386 libstdc++6:i386
sudo apt install git
git clone
cd appinventor-sources
cp sample-.gitignore .gitignore
git submodule update --init
sudo apt install ecj openjdk-8-jdk-headless openjdk-8-jdk openjdk-8-jre openjdk-8-dbg
javac -version
##javac 1.8.0_272
sudo apt install ant
ant -version
##Apache Ant(TM) version 1.10.7 compiled on October 24 2019
python --version
##Python 2.7.18
export JAVA_HOME=/usr
export ANT_HOME=/usr/share/ant/adtools/java/jdk
export PATH=${PATH}:${ANT_HOME}/bin
cd appinventor
ant clean
ant MakeAuthKey
##Total time: 2 minutes 55 seconds
/home/<user>/google-cloud-sdk/bin/ --port=8888 --address= /home/<user>/appinventor-sources/appinventor/appengine/build/war/
##in browser#localhost:8888
cd buildserver
ant RunLocalBuildServer
## Server running
##in browser# localhost:9990/buildserver/vars
##in browser# localhost:9990/buildserver/health