Phase • Animations made easy!

i think you need to provide java file of your extension.
it will help new extension developer.

So, please provide java file

I'm not bound to do everything people ask me to. You PMed for the exact same thing on Kodular community as well. Have some etiquettes while asking for something; don't order, learn to request.

Nevertheless, Phase is closed source and I don't have any plans to open source it anytime soon. So, please refrain from asking for it.


There are several open source extension you can find here and on Kodular community. And I'm not going to give you my extension's source code. Please stop asking for it.


okay no problem, do you know any open source code??

I'm not sure if this is a bug, but I'm having a problem with this:
The block:
Running the code gives this error:
If you could help me out with this I'd appreciate it!

Restarting the companion app should get this resolved. If it doesn't, try deleting the companion's asset directory as explained here.

1 Like

I reopened the companion and this time I got this error:
I want to do the other solution but the guide you linked for deleting the companion's asset directory says how to do it on a usb connected device, would you know what file I would have to go to for a companion app that's in the BlueStacks emulator?

Yes, I can confirm. I get the same error with ImageSprite component:


1 Like

Try this:


1 Like

Obviously, ImageSprite and Ball is not an AndroidViewComponent.


Oh, I didn't realize that was how the extension worked. Thank you! It works now.

1 Like

animations are great btw!

1 Like

Maybe 'slide in up' effect is inverted with 'fade in' effect. Am i right?

Animations are great! Fantastic work


Latest update v2.2.1 presented the error:

Runtime Error

call to 'io.shreyash.phase.Phase.AnimateComponent(,java.lang.String,int,int,int)' has too many arguments (7; must be 6)
Note: You will not see another error reported for 5 seconds.

@Ricardo_Lucena Did you tried this :point_down:

@shreyash right, it worked ... very beautiful!!!

1 Like

AIX: Google Drive

Now it says "Page Not Found."

The link works fine, when google drive "opens" the file click on download (in the red rectangle)

If this isn't working, check your browser settings


Working for me too