Phase • Animations made easy!

Also I think that in the Kodular Community the owners will, like here, give it for all, so if there is a permission, it will be for all. Isn't there also asked

Not yet.
Btw curious to know why you can't access Kodular Community?

Hi Yoshi,
Thanks for reaching out. Here's my consent for using Phase in your hackathon projects, and anyone using the extension is free to use it:

I, Shreyash Saitwal, hereby give my consent to <your_name_or_email> to use my free extension, Phase, in their project for MIT App Inventor Hackathon for the year 2020. Also, I allow MIT to republish the extension as a part of <your_name_or_email> 's project file in case it is required for the hackathon.

3 Likes

Thank you very much, I appreciate it.

Until the extension is updated it is useless with app inventor n184.

@Shreyash After latest update extension is not working, see below

1 Like
1 Like

Oh, thanks for reporting. I'm not feeling well since last few days. I'll update the extension once I get well.

2 Likes

Update - v2.2.1

  • Fixed the bug that caused java.lang.NoClassDefFoundError after the nb184 release.
  • Reduced the extension's size by ~20%.

Download

AIX: io.shreyash.phase.aix (81.3 KB)


In case you face any issues with the extension, please feel free to report them here. :smile:

6 Likes

Aparece el siguiente error al copilar : java.lang.NoClassDefFoundError: Failed resolution of: Landroidx/core/view/ViewCompat;
Note: You will not see another error reported for 5 seconds.

1 Like

Make sure you have the latest version of the extension :point_down:

1 Like

I KEEP GETTING THE SAME ERROR

java.lang.NoClassDefFoundError: Failed resolution of: Landroidx/core/view/ViewCompat;
Note: You will not see another error reported for 5 seconds.

Try re-importing the extension.

Are you using the extension in App Inventor or in other distros, like Kodular? If it's some other distro, it's likely that they haven't yet migrated to AndroidX. In that case, you should use version 2.2.0. You can find it here:

2 Likes

I get the same problem.

I have used the latest version... not solved :sweat_smile:, I am using app inventor

Please add on curred event block so that we can ignore the error

Post a test aia to reproduce this issue.

2 Likes

i think you need to provide java file of your extension.
it will help new extension developer.

So, please provide java file

I'm not bound to do everything people ask me to. You PMed for the exact same thing on Kodular community as well. Have some etiquettes while asking for something; don't order, learn to request.

Nevertheless, Phase is closed source and I don't have any plans to open source it anytime soon. So, please refrain from asking for it.

6 Likes

There are several open source extension you can find here and on Kodular community. And I'm not going to give you my extension's source code. Please stop asking for it.

4 Likes