Permissions help

I have used read and write_external_storage call commands in my my app, at first it asked for permissions but now , if I install it again my app says " there a are no special permissions for this application", what can i do to see questions again.

Once you grant this permission you don't need to grant it again, even if a new version is installed.

You'd need to uninstall the app then reinstall to see the question again.

Thank you very much for your help KEN, I have already uninstall the app and also change the name of it, but nothing, it keep on saying "there are no special permissions for this application"

So where is the problem?
Isn't it good that the user will not have to see that dialog again and again?

Off course Vknow360, but i was testing this, i wanted to see my app´s behavior, before I upload it to the Google playstore, they have to be according to the new rules.
Thanks for your comment anyway

This problem just happened today. My bluetoothLE has the same problem, but the one compiled yesterday still works normally. The new one cannot get permission.

Which permissions? Show the blocks or post the aia (a test aia).

Show your (relevant) blocks (or the aia).

And try this:

  1. Open a new project
  2. add the File component, → no blocks! (to add READ / WRITE perm. to the Manifest)
  3. ask for permissions at Screen1.Initialize:

Report ...

Post a screenshot of this message / error.

bluetooth1.aia (273.9 KB)

The new version cannot scan

and again:

I think it is Bluetooth permission but I am not sure

What (error) message did you get? Post a screenshot.

No error message but unable to scan Bluetooth
the same aia
I can't understand why this happens

"In order for Android 10 to detect BLE devices, the permission must be set to ACCESS_FINE_LOCATION (and not ACCESS_COARSE_LOCATION)."

https://devzone.nordicsemi.com/f/nordic-q-a/53938/android-10-need-to-toggle-location-permission-to-see-ble-devices

These permissions are declared in the Manifest of your APK:

<uses-permission android:name="android.permission.ACCESS_COARSE_LOCATION"/>
<uses-permission android:name="android.permission.INTERNET"/>
<uses-permission android:name="android.permission.BLUETOOTH_ADMIN"/>
<uses-permission android:name="android.permission.ACCESS_NETWORK_STATE"/>
<uses-permission android:name="android.permission.ACCESS_WIFI_STATE"/>
<uses-permission android:name="android.permission.BLUETOOTH"/>

https://developer.android.com/about/versions/10/privacy/changes

Thank you Sinier for your help!!, I will try again and do more testing.

Thank you very much for your kind reply Anke!!
I will try what you suggested me. However I have another question
I Understand that permissions that you have in the Manifest by default like the following:

Read Storage
Write Storage
Access to internet
Permission to see connections on network
Permission to control Vibration
Permission to see connections to wifi

These six are the ones we can handle,
in other words if you have a persmission listed in the Manifest you can grant permission or deny it. Am I correct?

But what about other permissions like for example:

Permission to avoid the screen going to sleep" I would need to add it to the Manifest but how?? could you please help me.

Thank you very much for your kind help.

Thank you Anke for your help!
I hope this may help Javier.
My problem was solved. I tried to find the offline version. The application compiled from the old version worked normally. I checked the release notes and it was updated the day before yesterday. I believe there are some changes after the update.(183c>>184)
Release Notes:
http://appinventor.mit.edu/ai2/ReleaseNotes.html

Dear Sinieer, Thank you very much for thinking about me I am glad to know that you have solved your problem.
I have checked the link you posted and I have seen there are changes since 30 of july 2020.

This is what I have added to my code.


This is the behaviour of the app after the code:
When I start downloading it says: "Do you want to install this application. It does not require special permissions". however If you see the code I apply for the permissions READ and WRITE

After app is installed it says the following:
"Application needs your permission to access to photos and multimedia files"

Either I Accept or deny gives me the error
It says:
Error 908 The permission "READ_EXTERNAL_STORAGE has been denied.

When I check permissions for the app on my mobile
It has permission but only to read but not to write

It works normallytest (1).aia (2.1 KB)

Guys

Instead of requesting READ_EXTERNAL_STORAGE when Screen1 Initialize,
request WRITE_EXTERNAL_STORAGE only

Once granted write permission, read permission should be automatic.

@ Javier you have a typo in the 2nd IF of the when Screen1 Permission Granted Block:

you have WRITE_EXTERNALSTORAGE
should be WRITE_EXTERNAL_STORAGE

You only need to test permissionName for WRITE_EXTERNAL_STORAGE

1 Like