Permission popup doesn't show up

I built some apps regarding txt file component and it worked well

and I tried to change some features then I found out there's new 'permissions' blocks

so I figured out that I needed to get permissions using the components, and this set of blocks doesn't give me ask permissions popup

rather it just comes with this alert

I can't build apps using file component anymore please help

Did you trry setting DefaultFileScope of Screen1 to Legacy?

The alert 'Error 908: ...' shows up when call permission blocks are executed. I mean the app doesn't even give me chance to get permission.

further I cannot give permission manually through settings app as shown below

It says there's no permission granted / no permission denied so I can't change anythings that has been allowed or denied

Enable the permission “Files and media”.

Oh actually I didn't know about DefaultFileScope and I'm now trying to resolve problems while changing it to legacy
thank you

No, if you try to save / read in / from the PrivateDir (internal storage), you don't need any storage permissions (READ / WRITE).

Your blocks are complete wrong, it should look like this:


I see it's been two years since you were last here in the forum. Unfortunately during this time you missed a lot of things/changes that Google "forced" us to do. The entire file system has been changed.

Read here first:


Thank you I think this really helps

I'm not sure I can learn it quickly so I resolve my problems soon but I will try out thank you