Paired Bluetooth list no longer shows up

Updated the MIT companion app on android phone and now no text appears in list picker screen to choose which bluetooth item to connect to.
This worked before updating to the new companion app. Using the same bluetooth blocks as before

Android 5.0.1

Thanks for the report. Nothing in this release should have changed the behavior of either of those two components. Can you verify that Bluetooth is turned on? Are you able to set the elements of a ListPicker from a list rather than from a BluetoothClient, or does that not work either? You may also want to include a screenshot of the relevant blocks to help us try and identify the issue.

Sorry sent emails instead of replying to this topic.
Tried uninstalling mit app inventor 2 on phone along with app in development. Re installed version 2.56 from play store and still the same problem. When I use the list picker before, after and the clock it works on an older app version but on the newer revision it just brings up a black screen that if pressed will connect to bluetooth but no listing of available bluetooth devices.
A smaller less graphic intense version of the app works fine and shows available bluetooth devices to connect to using the same blocks.

Does this tell you something ?

Can you show the blocks you use for populating the list? It’s hard to tell what could have happened without being able to see how you’re trying to accomplish it.

here is the info you requested thanks for your help

File size shows 3.35mb on download from MIT

Here is a shot from the designer
thanks Doc

I notice from the blocks downloads that there is no startup
use of these BlueTooth values for connection debugging:


Whether Bluetooth is available on the device


Whether Bluetooth is enabled


Testing those values might shed light on the problem.

Also see
from one of the BlueTooth sections of FAQ

1 Like

Thanks Abraham I’ll check out the references you sent and see what I can find out. The bluetooth I am connecting to is already paired to my android device. And connects if I touch the screen at the top. It’s as if when the .apk calls the screen to choose the bluetooth device it doesn’t print the text of what devices are available but still makes the screen area active. If I touch the blank top part of the screen it connects to the bluetooth device and switches back to my .apk screen that I developed in App Inventor 2. All of my buttons etc work as expected in my app. Kind of mysterious
Do you know of any size limits on the connect function for bluetooth or where I can find out how the bluetooth connect screen is implemented?
thanks for all your help

Thanks again for the suggestions. I looked at the first link and it seems to be where my problem lies. I will need to look closer at this suggestion to see what might be causing my problem. Also thanks for the other suggestions. I think I will change my code to incorporate the turn on bluetooth function. Great suggestion

Posting the exported .aia file would help diagnose any
problem with visibility of the BlueTooth device list,
in case it’s pushed offscreen by graphic elements on differently
sized devices.

This blog system won’t let me upload a .apk file how do I get it to a .aia file

Found it!!!
here is the .aia file Tested Nested1.aia (33.5 KB)

Here is my take on enhanced BlueTooth status checking,

The downloaded .png file should be draggable into the Blocks Editor,
or just edit to match.

Clock1 Timer enhanced error checking

(edit - It’s on the code server at
Your Code to Re-enter is: NAGY-OILY-BAN-OFF