Output does not install on some phones

Hello, we have an app that has been working for a few months, but unfortunately it is not installed on some phones

I thought the problem was with the code or plugins used in the app
But with an output of a completely empty app and without any plugins, the app was not installed

Is there a way to solve this issue or not?
Installed on many phones but not on some
Phone models include:
Xiaomi Note 11
Nokia G20
Galaxy a10s

Uninstall the previous version, then try to install again

Can you please provide a screenshot of the error?


I checked all the cases like this: cleaning the previous version, creating a new project and copying the information
Checking access to install the program

After checking all these things, I said that by creating a project and another app that did not contain any information, I tested it on the same mobile phones where the app could not be installed, and I came to the same conclusion.

Translation of the error message of the program not being installed

The program could not be installed

I apologize for the bad translation, I hope I got my point across

Out of twenty phone models, it is not installed on five models!!

are you using an extension? if yes, please provide a list of extensions used.

this was the reason here

Probably the "PushNotification" extension caused my problem. I have deleted it and now I can install my APP on my smartphone.


My dear friend, I had read this article and because of this, I made a completely empty app without any extensions or activities, but it was still not installed on the desired phones.

Again, I feel that the problem is with the software compilation model

Photo of extensions used;

And also two-file apps

The main file of the app and Oi that I used for testing

both apps installed fine on my Samsung A51 running Android 13...
which means, is is a device specific issue...
probably the extensions developer @Anke @vknow360 @Gordon_Lu have an idea?


delete one of the extensions from your test app, does it work?
delete another extension, does it then work?
repeat this until you get a working test project to find the problematic extension

The test app does not include any data, extensions, blocks, but it was not installed on the mentioned models

But just to let you know that I did what you said

Does the messenger from which you are trying to install the app have permission to install apps from an unknown source? Every app from which you run the apk file must have this permission.

It is true that this is possible, but I had checked this matter very carefully myself and the problem is not related to this case

So permissions are granted?

I checked all these items, but the problem is not with this item. Let me explain the problem like this, if there are permissions or blocks and whatever is on the part of the code, the program must be installed and when opening the program, the program will be stopped. I repeat again, I made an app called test.apk, which has nothing in it, and I compiled an empty project, but it is still not installed on the desired phones.

Does the problem occur if you generate the apk file in app inventor and then scan the qr code with app companion?

I think there must be something on your phones side. Your test app installs without any problem. Perhaps some security settings, antivirus program or something similar.

Try to install this (empty) test app:

No, unfortunately it was not installed on the relevant models

Interesting... I've never received information from users of my apps that they can't install them. In my opinion, some security on the phone is blocking the installation.

unknown sources not allowed ? (e.g. sideloading)

I suggested this idea above, but the author claims that this is not it. I tested on my phone and turned off the ability to install from unknown sources. Then, when trying to install, it displays a message with a button where you can go to the settings and enable the installation option. In the screenshots from the 3st post, this button is not visible.

1 Like

Set the language of your test devices to English in the Settings, try to install my test_2.apk and post screenshots of the (error) message.