OutOfMemory Error message

Good day. I just started using this platform as part of a Mobile App Development course, but my emulator loads correctly, then “freezes” for a while, then gives me an error message “Companion: OutOfMemory”
What am I doing wrong?
I really need to be able to use this platform.

Usually OOM errors happen when using large images, especially in the older emulator. Have you tried loading a simple app first?

Thank you for he prompt reply.
I have no images or anything on it yet. It’s a brand new project. with no files.
I downloaded the program on your website for the emulator.

Is there any possibility to clear the cache or memory or something?

Can you export your .aia file and post it here?

Can you share a screenshot of what you’re seeing? It will help us better identify the source of the problem.

Now it tells me the Companion closed unexpectedly… :sob:

Any blocks ?

MIT Screenshot 2

It is still very basic to learn how it works.

Describe your PC, your Internet connection speed, and what else you have running on your PC at the moment.

I do not see an Out Of Memory error message in your screenshot ?

I have a desktop pc, running windows 10, Internet speed is 112.10 Mbps (Speedtest result).
No other programs are running at all. Firefox and MIT, thats all.

Can you please help? I NEED to do the course.

Have you tried using the Companion over wifi on a real device ?

Riaan, we need to see your Blocks. (If there are no Blocks yet, then that is the problem - nothing to run).

How much RAM does your PC have?

This short video tells how to find out details about your PC hardware …

It runs the built-in Microsoft diagnostic dxdiag.exe, reporting on the hardware found.
If you ask it to save results, it will leave a text file dxdiag.txt on the desktop for you to read or upload to us.