Online SDK disconnecting and crashing the app when testing on phone

The Online App inventor SDK was working perfectly well until yesterday. Today, the SDK suddenly started crashing consistently the moment I try and connect to it to test the latest version of my App on my android phone. The SDK now shows two 'My Project' tabs. Restarting the laptop did nothing to improve the situation. It keeps crashing.
I also checked with previous versions of my APP and it still crashes. So the issue is not related to any change in my App.
Please help.

MIT app inventor had 2 My project tabs by default ; there is no change in that & restarting your laptop won't be helpful at all
Can you tell me when your app crashed?
when you installed your app or when??

Try disabling project autoload (settings) or use this url to start App Inventor

AI2 Autoload False

thanks, will try and revert

No change. I tried making a 2 screen test app and that worked well and did not crash! What is awful is that it is not some small change I made in the latest version of my app that is crashing it. Even the older versions which were working perfectly well are now crashing! I also tested the app on two different android phones and my app crashed on both. I wonder if it is the new update of the Online Inventor that is now no longer compatible with my code? Especially since the problem started just this morning (12 hours back). And if that is so, is there a way for me to revert to the older version of the online App Inventor SDK and test on it?
I need Help desperately, especially since I have put in more than a 100 hours of work on my app and cannot afford to do it again!!

Do you have extensions? Some extension developers may not yet have updated their extensions to work with the new update?

1 Like

Yes, I have been at it trying to find out if any of the extensions are misbehaving. I have finally homed on to the firebaseDb experimental extension. As long as I use the default settings. The app does not crash, however the moment I add in my specific firebase token and firebase URL, the app crashes. The funny thing is that it worked well till last night.
I checked the firebase security settings and it is open to all (though I get a warning to set security rules).
Any one here who can help me with the realtime firebase Db security settings?

FirebaseDB is a component not an extension.....

Let me test...

FirebaseDB working OK here, using my credentials to online Firebase

Your "open" rules should look like this:

  "rules": {
    ".read": true,
    ".write": true,

Yes these are the rules in my FirebaseDb too

Finally cracked the problem!
The FirebaseDB bucket data had some issue (don't know what) and that was probably causing the app to crash. Since the data was not important as it consisted of only dummy info, I simply deleted it and created a new bucket.
And that's all that it took to get back on track! App now working perfectly.

Just sharing this info so that it could be of help to others. Thanks Tim for reaching out to help!

Good to hear you are back on track :+1:

Thank you.