Old app no longer works


I am coming back to an app that was developed about a year ago. At the time it worked fine in the companion. Now it crashes at start. The app has not changed since I last worked on it.
Is there anything in the recent updates that could cause issues?

Search didn't show anything related.
I am using a Samsung S10 running Android 10.

is there any error message? which one?
could you please provide a screenshot of the Screen.Initialize event?
to find out more about the runtime error you can use logcat


Probably Martyn. Once again during the past year Google 'upgraded' its security protocols necessitating changes to how App Inventor works. These changes are mostly related to how files are accessed and stored. The AI changes are discussed here Release Notes for MIT App Inventor 2 .
To receive specific advice you need to share some of your Project's code as outlined by Taifun.

@Taifin. Thanks. Looking in to it.

@SteveJG. Went through the updates. Nothing jumps out at me. Will keep looking.

Any extensions?