Not connecting to Amazon and not generating APK

Hi, I have a problem with my APP INVENTOR project. 2 days ago, the project was working perfectly, it is an Alexa Messenger. However, today I tried to log in to Amazon to test and it doesn't log in (even though 2 days ago it did). Moreover, I can't generate an APK file because of a "Build erver internal error" I would like a bit of help about this issue. Also, I would like to know how to test it in a real Alexa (ut I can't generate an APK, so...)
Thanks in advance. I'm looking forward to your response.

Hello Albert, welcome to the forum!

Are you certain the last successful run was two days ago? That means your App was compiled under the latest App Inventor version, nb191.

Have you made changes to the App between the last time it compiled and now?

If you have time for a large coffee, go through this check list on my site:
ProfessorCad: Tips & Tricks Cannot Build/Install/Run APK

Hi! Thanks for your fast response. The last time I tested it with Companion App and it worked was 2 days ago. Yesterday, I made a slight change because it didn't work that day, but it kept not working. About the APK build, the project has not any kind of error or warning. I upload a photo of that error. Thanks.

Building an APK only makes sense if you have an app that works alongside the Alexa skill. The build menu only appears when viewing an app screen. If that's what you're trying to do, then you should be good to go as the system wasn't set up to point at the new release of App Inventor.

If you're only looking to test an Alexa skill, then we need to figure out why you cannot log into your Alexa developer account. Do you have a specific error message you see when you attempt to log in? After you try to log in, what do the buttons below the testing window look like?

I do have an app with an interface, but that error appears. I managed to log into Amazon but then ANOTHER error appeared that did appear already this morning when trying to test. I haven't made any change from when it worked (I only changed a thing about the name of a tag)

Please include a screenshot of the testing window.

like this?

So just to clarify, you hadn't typed anything into the testing box before you got that message?

I typed Alexa, tell [my skill name] to read my message. And then it appeared that.

Unfortunately, you've scrolled the testing window or something so that content is not there to see. The reason for this message is because Alexa is confused about how to route your request (since it learns utterances globally), and has inadvertently picked another intent with the same or similar utterance to yours. However, this can also happen if you mistype, which is why I wanted to see your testing window but what you've typed isn't being shown in the screenshot. Try verifying that you don't have any spelling errors and try again, but if it still isn't working please send me a private message with your App Inventor account, project name, and skill name and I can reach out to the technical folks in Alexa to see what's going on.