Not able to see changes made in while running localhost

I am working on the issue #2408. I tried a solution but it didn't work, so to figure out the problem I made all the four makeDictionary methods (in under components directory) return empty dictionaries. But that did not impact my app at all, the app still worked the same as before and showed the same dictionary.
I made similar changes in the makeList (in and they also didn't seem to effect the app either. I then made some simple changes to the UI to see if I'm working in the correct repo and those changes were observed after compiling.
I think I am missing some compilation steps to see the changes I made on my localhost.
Steps I use to check my changes:

  1. Run ant in appinventor-sources directory
  2. Run start_appinventor in appinventor-sources directory
  3. Open localhost:8888 and make a new project as shown in the screenshot.
  4. Connect companion app to verify the changes.

Any help would be really appreciated.

Are you using the companion, which is compiled with the latest changes you made when running ant command? If not, so you can find it at appinventor/build/buildserver/MIT AI Companion.apk
See also the Appinventor Companion app section here:


Thank you so much, this fixed the issue.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.