NFC doesn't work

I've installed the apk with NFC reader on my mobilephone, but when I try to read a NFC TAG the app is bypassed by the operating system..
How can I solve?

Welcome Matteo.

Perhaps this will help NFC read/ write tags between phones not working (.aia file attached) - #7 by codegirls

1 Like

Ciao Matteo,
I worked in the past with NFC Tag and I had the same problem, this happens (my opinion) because there isn't in the manifest the android.nfc.action.TECH_DISCOVERED, the nfc_tech_list.xml in the apk and there isn't the foreground dispatch (I tried to solve in my extension but I could not) that tell that your app has priority other app installed that handle the same intent.
I wrote this that could help You to understand.

If You want You can try my extension that use Mifare Classic and Ultralight it depends what You want to do



Ciao Marco,

I've try your exstension but there is the sanme problem. The operating system say: Nuovo tag raccolto - TAG vuoto. If I use NFC Tools (App) it work perfectly.
I'vetry your exemple but with the same result.

I'm using NT AG215 NFC cards. Same problem. The operating system bypasses the app and reads the blank card. Unable to write, unable to read with App Inventor app.

Thanks Marco for the useful extension. The latest one works fine reading Ultralight. I get a proper read of the records with the right data in each record (total 118 bytes). But I cannot get it to write. Any examples or suggestions? The tag has 540 bytes of memory (135 pages of 4 bytes each). I need to write single record of 64 characters into the Ultralight. Any help appreciated.

Hi @DrWino,
with the extension, i also put a sample project where you can read and write mifare ultralight did You try?

MifareInfo.aia (project test)
Best Regards

Thanks for your reply. I am using your sample app. I get the startup page of my phone. When I touch to Ultralight tag I get a new screen titled NEW TAG SCANNED and then it shows the contents in the memory in the Ultralight in the form of records. If I return back then I get your startup screen only showing Uid: and Type: labels but no data is shown. Is something hijacking your app ?

I conclude the default NTAG app in the smartphone is getting the data before your app. Is there any way to disable that ? I did not get any popup choice on install.

Hi @DrWino,
I tried my sample project I was able to read and write a Mifare Ultralight EV1 Tag.

I think that in your smartphone is set to use always a specific app when you approach a Tag this is the reason my sample doesn't work correctly, to override this problem the extension should have the tech list and manage the intent. But I was not able to add this features in the extension.
Here I wrote about this problem

Maybe someone else know how to solve

Best Regards