My app won't open on my phone

I've created an app for my project and I want to try and open it on my phone. The download seemed fine until I tried to open it and it kept kicking me out every time after downloading it. No matter how many times I reinstalled it or re downloaded it from the build section, it just simply refuses to open. I don't know what I'm doing wrong.

The phone that I'm using is a Samsung Galaxy A30

What is in your Screen1.Initialise event ?

Screenshot 2023-04-24 163916

Would you like to see what the design looks like in the viewer?

Would prefer to see if you are running any blocks in the Screen1.initialise event....

Maybe just show all your blocks.....

It's all here in my first post

To correctly download all of your blocks, right-click an empty space in the workspace and select Download Blocks as Image. Your blocks will be much more readable and clearer.

It's all mentioned in the guide.

Have you tested using the companion app ? Does it work OK there ?

So I did try and download it the companion app on my phone and scanned the qr code. However the loading bar was stuck in 20% for quite a while.

oh wait nevermind it works now. Guess it was my connection

Actually it did originally work when I used it the second time but now the same issue came about when I wanted to try and open it again

We might need to see your aia project file to find out what is going on.

This was what happened the 1st time and 3rd time. I have no idea how I got it to work the 2nd time

TrackPoint_UI2.aia (3.5 KB)

As I'm unfamiliar with Firebase however, I'm getting this error with companion

and with apk if I'm not mistaking bunch of receiver/service stuff is missing from manifest file


Probably need to create a new project on the us-central server. The Firebase component will work with that.

If you want to use the same project then do not use the Firebase component, but use the web component instead. See here

2 posts were split to a new topic: On Samsung A51, A52 the app try to open and then close