Multiple Download from Google Drive are not supported anymore?

Hi Every one, is any abody here? I have few question about updates of MIT App Online? starting this month 8/25/2021, i can't able to download multiple files from GGDrive even i tried to use the example provided here []. please help.(

You probably need to set a different file path to store the files, you will have problems downloading files to the usual shared storage areas. You might also try changing the scope to Legacy in

You might also consider this method, which should work with Android API 30 / Android 10/11

(note: it will also work with public files)

Google Drive does not suppert Multiple Download anymore (about 20 files are ok but not more)

A possible solution for you is here:

Please tell, do you have a resource / link about this ?

There is no official statement about this, but many posts eg:

1 Like

This is not a new thing, it has always been the case.

Regardless, it is, I believe, not related to the OP's problem, which is more likely to be file storage locations due to the targeting of API 30.

1 Like

Hi TIMAI2, Thanks for response. I doubt there is an issue update at ai2.appinventor online? Maybe GGDrive are not connected in this issue? Some of example from puravida like Multiple file download from server of won't work now. Here is the example In this case i used un-updated offline installer from localhost:8888/login/ But working perfect unlike online. Do you have any idea what goin on? I really appreciate your reply.

Unless you have hit your quota for the 24 hour period, there are no issues with downloading files from Google. The googlesphere knows nothing about AI2, which is just sending http GET requests.

You need to show your relevant blocks - where are you saving your files? Is your device able to save to that location with the new release. What file scope are you using?

This Blocks example are not mine.

iget it here . this is working last 4 days, but now can't abe to do that.

not really much use then - and they are not for downloading from Google Drive. Regardless, if you are using these blocks verbatim then as previously indicated, your problem is probably here:


Set a path to your Application Specific Directory (ASD)

Search the community, plenty of advice on this.

I already change that and i tried to use another devices but i'm facing the same issue. Anyway thanks for the time. Have good day. image

As you have found that path will likely not work either. Use the ASD path to save your files.

Been doing some testing, there appears to be an issue with the web component itself.....

Yes, seems there is an issue with the web component. Perhaps @ewpatton can shed some light. I tried the usual trick of changing the app scope to Legacy but that had no effect.

webComponentTest.aia (1.9 KB)

Thank you @TIMAI2, I hope they fix it soon i realy love this APP Somuch.. i think for now i should use the offline MIT app. Or if thier some aix extesion for web component much better..

Try this extension to download (multiple) files from GD to the ASD:


Also you could use:

(works with public files too)

1 Like

I really appreciated for some tips @Anke, i don't have any idea that this extesion exist. Thank you somuch. I look at it.

1 Like