Multi-line button issue with Theme → Dark, → Device Default (works only with → Classic)

Since when is it no longer possible to create a multi-line button as soon as "Classic" Theme has not been selected, which practically nobody does anymore? Did I miss something?

That was never a problem with either AI2 or Kodular. With Kodular it will of course continue to work.


Theme: Device Default

Theme: Classic

1 Like

Note: This only seems to be an issue with Companion.

Thanks for the report. We'll have to double check this and figure out what might be causing the issue.

I tried recreating this bug on my device and it seems to be working fine for me. I tried all 4 themes, Classic, Dark, Device Default and Black Title Text and they all gave the desired output.
WhatsApp Image 2021-03-08 at 10.19.55 PMWhatsApp Image 2021-03-08 at 10.19.44 PM WhatsApp Image 2021-03-08 at 10.19.35 PM WhatsApp Image 2021-03-08 at 10.19.20 PM

I wrote "line1\nline2\nline3" in the textbox for the button.
Am I doing something wrong here?

It could be a device-dependent issue. Some manufacturers have made customizations to the standard Android theme and the companion and compiled apps behave slightly differently in regards to this. If I had a guess, the issue is probably on a Samsung device since they tend to be the ones who do this the most.

Yes, that's right, I hadn't tested this on multiple devices.

Yes, this issue occurs e.g. on a Samsung Galaxy Note8 (Android 9), but not on a Pixel 2XL (Android 11) or a Xiaomi Redmi Note 5 (Android 9), and also not on a Galaxy Note 3 (Android 5).