MM/dd/YYYY issue or problem


I have made an app. in which I use DatePicker, see attached blocks. This app works OK with Android 10.3.2 while it does prompt an error that clock should have format MM/dd/YYYY - see attached image:


And that is how I have it.

blocks (1)

Any idea how to solve that?


There is no Android 10.3.2 version, but OxygenOS 10.3.2 for OnePlus 6 / 6T.
I have no issues with this device on Android 10.

1 Like

According to the Java link, it should be yyyy instead of YYYY.

y Year Year 1996; 96
Y Week year Year 2009; 09

The AI2 message is wrong.

1 Like

Thanks ABG - that solved the problem on an old Samsung phone.

Best regards

On OnePlus 6 (Android 10) both work.

Hi Anke,

well the problem was that blocks would not work on Android 6.0.1. It all worked well on OnePlus 6T (i.e. Android 10).

I did find out another “hickup”; namely Android 10 phone sends AM or PM information in local language, which in my case is “dop.” and “pop.”, while Android 6 refuses to send AM/PM in local language and keeps sending AM/PM no matter what I set on the phone. I did overcome that issue on the side of program that runs on my MCU.

Thanks & best regards