ML4K doesn't work on my app inventor

Hello, I am a teacher in south korea.
I use app inventor to teach my students learn coding.

I am making an AI camera model for "coke" and "pocari sweat" and this will be the student's lesson if I find my way!
I've been trying hard to make this work and found lots of tutorials but it's not working well. I seriously need help.

This is what I have done through.

  1. Made machine learning model on ML4K(labelled "coke"/"pocari") and trained it.

  2. Imported extension to the App inventor by the way it tells on ML4K.(picture below)

  3. designed & block coded as below.

  1. I saved my project and connected with my Android smartphone using AI companion. After taking picture, this error pops up all the time. I tried re-train the machine learning model on ML4K, but didn't work.

if anyone know what I've done wrong.. please teach me.
Thanks a lot!!

how long did you trained the model it happened to me like months ago that if the model is last trained a day ago it might not work. so can you try train again and import immediately.

1 Like

Thank you for the advice!
But the problem is all the ML models are freshly made for at least 10 times.... :frowning: It shows same error after I make MLmodel on ML4K in 3minutes.

1 Like

Hi, Jammy!
I've got the same problem as you and I don't find the key. I thought that device could be same restriction, but the camera and store have been share with ML4K.
Do you find out the solutions.
I'd appreciate too much if you share the solution with me.