MIT App Inventor not showing images placed on the canvas when displayed on iPad

My class is doing the MIT App Inventor unit/part in our class, and following the PLTW instructions, you are supposed to create a red canvas and add images to it. The app is Activity 1.7: Let's Create A Game. Me and my class do not have the images display on the red canvas when we view it on an iPad via the MIT App Inventor app.

As you can see above, it is on the screen, but when viewed on iPad it does not show. Any fixes for this problem, such as having to configure something in the Blocks tab or in the Properties tab?
We've tried to do things like change the Z layer and mess around with "heading" but no matter what we did, the images never show in the app.
The images are there, and do get uploaded to the iPad, as if we try to put them at the bottom of Screen1 we are still able to see the images.

Help please!


Welcome Dino.

What happens if you use the Emulator or test your app on an Android device?

Your problem could be an ios issue or a coding problem. Knowing the above works for your Project will help someone to provide specific advise.

When I try to use the emulator that comes installed on the computer (named aiStarter, opens up a command prompt window) it will open the emulator, but nothing will load in the app, including all assets, text boxes, etc.

My class also does not have available Android devices.

Here is the .aia file with the images attached. It's as far as I was able to get.
AC_1_7GermFighter.aia (2.6 MB)

I know this could be an iOS issue and it possibly could be a coding problem, but the .aia files were provided by PLTW and they had specific instructions you could follow.

This either indicates an issue with your code or the Project cannot be run in the emulator because of it's size. How large is the Project? (aia size).

I would try to find a friend who has an Android and see if the Project loads on his/her device. Sometimes the emulator can be fussy.

The project (aia size) is 2.6 MB, just as the file I uploaded above, AC_1_7GermFighter.aia

Hmm. Find a friend with an Android :cry: That is a large project to run on the basic emulator. :slight_smile:

My teacher said that he has figured it out but I'm not very sure what he has done to figure it out.
The project I run is runned on an iPad instead of the aiStarter emulator, by the way.

Images show on Android device with companion

Great. A guess is there is/was a coding issue. You could ask him what the solution was if you are curious.

Glad you can work on your iPad now :slight_smile: A guess is the emulator cannot handle the Project for some reason but a device (iPad and possibly Android can).

Try this one:
AC_1_7GermFighter_2.aia (2.6 MB)

iPad Pro:

I am also having a similar problem of image not uploading in imageSprite when testing with iPad pro 11. The same project works on android. Please can u help with this issue.

Did you test my aia? (post #11)

We are facing this issue of images not being visible on ImageSprite on iPad and iPhone but it works fine in android. This issue has been reported recently. Please help us with this issue.

How did your test of @Anke's aia work out ? (post number 11)

1 Like

I already did that.

Which companion version are you using? The Canvas bug should be fixed in the beta version 2.64.1 available in TestFlight.

We are still stuck with the same issue, the image not appearing on imageSprite component. The files shared here was also tested but it didn't work. I am facing the same issue with students having ios devices. It would be great if someone can help with it.