MIT AI2 Companion not working at all

My AI2 Companion isn't connecting to AI2 for some reason. I've done everything I could or found on the inter webs to troubleshoot the problem but nothing is working. The app starts fine and I select the QR option and it reads the code and everything but then nothing happens. I've tried putting the code in manually but nothing still. The Emulator connection works fine but the companion is killing me.
After scanning the QR, if I leave the Companion running for about about 2 minute or so unattended It generates an error like "Error 1103 Couldn't connect to Key=" something something, it's quite a long string of characters.
One odd thing that I've noticed is whenever I log in and select my project and go to connect menu, the "Refresh Companion Screen" Option is enabled even before attempting to connect. I don't know if it was like that before or not but it is enabled on the first login for me, always.
I've been using AI2 for quite a while now and have never had any problems, but now I'm frustrated. I've tried legacy connections, I've uninstalled and re-installed the app, I've restarted the PC and phone, I've double checked the connections, reset the connections, nothing is working. Help me please.

This is a bit ambiguous. After scanning the code, does the dialog with the QR code disappear? If it disappears, does the connection progress dialog appear? Does it successfully negotiate the connection and transfer assets (if any) then go away? Or something else?

If I had a guess based on the error message you've transcribed, I think the issue is that your phone is unable to connect to our rendezvous server at This means that in AI2 you won't see the QR code disappear (that only happens when the initial contact has been made with the rendezvous server).

Try accessing the rendezvous link above in the browser on your phone. If you get an error, please report what it is here. If that works okay, there is some other error happening that we will need to track down.

If you're on a school or corporate network, make sure your network administrator hasn't blocked access to subdomains of


Nope, Nothing Exactly happens, The dialogue goes away and the the 6 letter code form QR is visible in the textbox and then nothing, nothing on Companion and nothing on the PC Screen. On PC, the QR remains visible unless I press the Cancel button..

The Link is not currently accessible form both, Phone and PC. It says Connection has Timed out.

Right, so something somewhere is preventing you from resolving the IP address for this server. Are you able to see a page if you go to

First of all, many many thanks for your prompt response and your time.
Secondly, I'm unable to access both addresses. I'm on my home network and have no firewalls or anything on. I think my ISP or someone in between is filtering links that "They" don't understand. Because by using any available online proxy service I can access the server without any problems. Any other rendezvous links that I might be able to use?

One last thing to try is seeing if you're able to view it when using HTTPS:

Nope, still not accessible..

Unfortunately, I'm not sure why your ISP is blocking your access to our server and you'll need to reach out to them for resolution. If you want to test on your device and you've set up the emulator package, you can use a USB cable to connect your phone to your computer and select the USB option from the connect menu, but this requires keeping the USB connected for the duration of the session otherwise the connection will drop.

Many many thanks for your time and effort. I'll use the USB Connection for now, and will launch a complain about this issue to my ISP.

1 Like

I have the same problem in my case when i type the 6 letters and press connect i see a progresses bar that stay up to 35 % and disappear but the companion dos not sow the screen from the app inventor if i select to use legacy connection then i can see the screen of the inventor on my pone for 2 or 3 seconds and after disappear and i have the message on the inventor that the companion disconnect.
I try to access the web page with or with out domain name and i have the same error the server is taking to long to respond.
the companion app freeze after that and i have to restart it.
I test the companion o two phones same problem .
i am using android phones

Try to eliminate two possible causes

Internet Speed is too low

Project is too big or stuffed with too much media

internet speed no way i have fiber I will try the second
thank you

Mike, make sure you optimize all images for Android:
ProfessorCad: Tips & Tricks Images

This list applies to Companion as well as a built APK:
ProfessorCad: Tips & Tricks Cannot Build/Install/Run APK

I will try it thank you