Missing BLE but not really?


I have an app that is starting to take shape. There is still an issue, however. When the app turns on, it gets location permission from the operator. It then connects to the local weather. Everything is fine until I press a button (ATMO) to open another virtual screen. Before I can press the a START button at the top of the page, I get a darkened screen with the message that no BLE is available. I can touch outside of that message box and it goes away and I can than connect with my START button. I have tried reconfiguring the block several different ways and I still get the (ultimately) false "No BLE" message.

The Call Bluetooth.Connect in the when atmo block is redundant. I added it from the start block to see if I could bypass the error message.

Might someone have a look at the code in my When ATMO block (below) and tell me what I need to do? I wanted to add another "when" or "if" statement to the block to achieve this but I don't see a means of doing so.

Asking to use BLE immediately after requesting a connection is premature.

You need one of these
where you can move those 3 BLE read requests.

1 Like

My hero;)-

I haven't yet caught onto the fact that certain conditions can stand alone and do not require nesting. I was trying to place that [when BluetoothLE1.Connected] block inside of the [when ATMO_Button.Click] block and the program was having nothing to do with that. Thank you for more clarity!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.