Micro:bit v2 and App Inventor micro:bit extension?

Hi Friends,
I'm working on a project that will have a micro:bit v2 connected to an app, hopefully developed in App Inventor.

Does anyone here know if there are limitations in the micro:bit extension with respect to the v2 of micro:bit? (I dug through the forums for a bit, but didn't find references to the new version).

And while I'm at it, do are extensions supported in the iOS companion?

Thanks all,

1 Like

We haven't tested the new micro:bit against the existing extension. Assuming it uses the same UUIDs for its services, any existing functionality should work. We will need to put some effort into supporting the newer hardware on the v2 though, so your best bet in case might be to have a sketch on the micro:bit that handles the hardware side and use the UART as a go-between until we can update the extension.

Extensions are not supported in iOS due to an App Store policy against loading binary code not reviewed by Apple. For our IOT and AI offerings we are hoping to build the functionality directly into App Inventor going forward (but I don't have an ETA on that yet).


1 Like

Hi jsheldon, sorry if I disturb you, I'am trying to write an app that send data from microbit to appinventor app using uart. I've found a lot of example where app send data to microbit, but no example where microbit send data to app. For example I write a microbit app that count steps and each 10 steps I want to write back data to the app.
Can You help me ?
Thanks in advance for your answer.

Hi there. I switched from working on this to another part of the project shortly after the last set of messages, so I'm afraid I don't have anything to report. I may take it up again in the coming week or two, though, and if I have any luck, I'll post back here.

If you get UART to work to report from micro:bit to app, I'd love to hear what hurdles you had to overcome.


We tried to make a step counter using Micro: bit V2 and made an app using MIT app inventor. After facing some issues we tried with v1 and its worked fine. Issues which we are facing are:

  1. Micro: bit V2 Bluetooth isn't getting connected easily as compared to V1.

  2. V2 is unable to send data to the phone using UART whereas V1 is sending successfully.

I think Extensions needs to updated or something. Can Anyone help?


We are trying to establish a connection and exchange data between micro:bit v2 and MIT app Inventor app and many times it fails at establishing a connection. Even after successful connection, there is no data exchange. We also tried on micro:bit v1 and it perfectly worked fine.

We are in need of urgent help.

If you can upload a .hex and an .aia that shows the problem, I can try to help you.



This text will be hidden