ListView fantasma :-)

Hello everyone,
I practically inserted a ListView in my app; but the strange thing is that inside the Designer it is present; while when I run the companion..the not displayed: thinking: P.s: Obviously the ListView has the property Visible = True

If a Listview has an empty list of elements, or elements are not set, then it will not display in companion or compiled app.

@TIMAI2 rightly as you say, if a value is missing within the ListView; it has no sense to exist: +1:
But when I go to add a numeric value to the ListView; I get this error:

The operation add items to list cannot accept the arguments: , [0], [100]

Pls use make a list + this label text

@Spicy_Topics I had already set the variable as "create empty List". However I used for the first time in this case, also "make a list"; but the error displayed is the same.

The problem is in with the elements only. Right click on yhe elements, click do ot and shate us the result..

@Spicy_Topics now start saving the numerical values; but he puts them in brackets giving me the same error as before .. and obviously, he doesn't average the values themselves. :thinking:

but no problem for me even if i use no make a l ist block..


@Spicy_Topics in the end I tried to create a new screen and everything works perfectly for me. It will mean that Mit App Inventor cannot manage many components within a single Screen.

This is not true....

@TIMAI2 In my case, however, by creating a new screen; there were no more problems.
But then, reading your answer; I tried again to launch the ListView in the previous screen;
and despite the many components inside .. now it works !!! :thinking: :thinking: :thinking: :thinking: :thinking: