List view problem after new release (23th, Aug)

Works like this

dependentListviews.aia (3.4 KB)

gets a bit upset if you do not clear down after listview 3 selection and try selecting an item from listview1 again

Who should that help?
Of course, it should work as I intended in my test app.

anyone who wants to use dependent listviews....

Yes, maybe, but then that's unrelated to the topic here.

You should re-read the OP

Thanks @Anke. That's very strange behavior indeed. I'll see what we can about a fix.

1 Like

English is admittedly not my native language, but I can't read anything that relates to your answer.

1 Like

Thank you for your efforts to resolve this issue. :slight_smile:

Same observations here.

Making a selection in one lv (listview) causes an additional selection in another lv, and sometimes crashes my app depending on what actions are triggered by the selection.

I like the more compact lv appearances though...

I've added a small app to the gallery to display this behavior.

The app is named ListviewTest210825.

Here's a direct link to the app.


i have the same issue, how did you solved it?? even when 3 listview are in same screen app just crashes ... i was just about to upload my app to google play store to update my clients and now this is a big problem i can not solve

Is there a way to revert back to a legacy version of ai2 in order to compile broken apps to a usable state?

Actually, I am starting to study other block language for my project!!
I don't know when this problem will be fixed, so I recomend that let you move other block language.

Use the server

1 Like

No complicated projects are needed to show this error. Blocks are also not required. Just add two ListView components to a screen with several items. For example, by clicking on the second item in the first list, the second item from the second list is also highlighted. It seems that only one ClicListener is created for all lists.

test_listview.aia (1.2 KB) exhibits the same corrupt behavior...

:pensive:Does anyone have a workaround for this problem?

Of course, test in compiled apk, or in older version companion v2.60.

you will need another companion version for the code server...
you can download it from the menu Help - Companion Information


I have tried to do a project by other companion, but because my project was made by last verst
project wsanot open.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.