List Index Error Appears After modifying Layout

I have (had) a working app. As part of cleaning the interface up, I shifted some elements around in the designer. Now when I compile the app, an error is occurring, just after I connect to bluetooth and receive some data.

This is the error:

I'm having trouble tracking down exactly where the error may be occurring in the blocks.

Unfortunately, I don't think i'm able to use companion, because it shuts down when I connect to bluetooth.

Is there a way to narrow this down?

See the error, you have aet blocks to select the 2nd item of n list but unfortunately that list have only 1 item.. also may be you may tried to take the length of the list (that list doens't have any data so it returned as 0 and you tried to take 2nd item so it throws error)

The best suggestion is, Please post your blocks as png file here. Go to blocks part , right click on mouse, download blocks as png file then upload it here using the option attachment


Part of my code uses a TinyDB to store ongoing data while the external bluetooth device continues to run, but the app may close or otherwise stop running.

The issue was - in the middle of an operation and in my hase i've been clearing up my app code and interface, but also saving the project with a new name (not using checkpoints). When I last did it, my app reinstalled (rather than updated), so I lost the TinyDB data.

The code was trying to read the list data from the tinyDB that wasn't associated with the "new" app.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.