LENGTH block does not count spaces

When counting the space character with LENGTH, it doesn't see it. For example, there are 20 spaces in a textbox. When I read it with LENGTH it says 0 characters. Actually I need to use 20 character space. Because I will replace each space character with another character I want in the program. LENGTH result=0 even though I don't use TRIM.
If I type a+space+d, the number of characters=3. If I type a+3*space characters, the number of characters is =1.
How can I fix this.


Post the aia or a test aia.


You could use a label instead of a textbox or - if input is wanted - as an alternative: use a notifier text dialogue as input

If I take a textbox and type "a" followed by some spaces the length is given correctly as it is in the following example:


TextBox output: "10"

Sorry for this question. when I am sending my program to you . I tried on new program. LENGTH is correct worked. I searched why. I found error in my program. textbox is part of other textbox. And while I convert, I had use trim. if I use (a+3space), trim command, cuting spaces in this string. this situation show length wrong. if I use a+ + b length is correct because trim not working on this string.
textbox 12 show problem. but error is on other procedure.

Thanks solved now.

1 Like

Thanks for your help. I found error. when I convert string, I had used trim command block. Trim command cutting left or right spaces.
I understood .
Thanks Regards.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.