KIO4_PDF is not working with TaifunFTP

Hi guys and gals and non-binary pals,

I am currently developing an app to take pictures, save them in a PDF and send it to an FTP Server. The extensions I am using are:
KIO4_Pdf, found here Create PDF file Extension. Layout to PDF
and TaifunFTP, found here

However, the PDF is never sent to my server.


You can see my PDFpath is a joint string of file:// and the path of the PDF extension. The label returns the following: file:///storage/emulated/0/Android/data/PACKAGENAME/files/NAME.pdf
According to the FTP documentation under section Example App: FTP Demo the url seems to be correct.

Here is the instruction to fill my PDF. I use the same path as above and I do have a filled pdf in that directory.


And here is a log from my FileZilla server. You can see the connection is established but it never starts a transfer. I tested it with the FTP Demo app provided which does send a picture to my server.

Is there something I overlooked? Is the FTP extension unable to send PDFs?

Have you tested sending other files with the same method?

I've tested something and I found out that the PDF is not saved to the directory that I called in my label. Instead it's just saved in /storage/emulated/0/. After changing the path in the upload block, it worked out. It does seem weird that it's not the same directory as mentioned in the other thread but it works out now so whatever.

Are you using Android 10?
In Android 10+ the files must be created in ASD.
Can you try this extension update?

My phone is on Android 9 and the Zebra TC20 I'm building it for is on 8.1.0 . I mean, it works now so I wouldn't care that much.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.