Hallo everyone.
I created my app with MIT app inventor but when I tried to install the app on my mobile with Google Console I had this error message:

java.lang.NoClassDefFoundError: Failed resolution of: Lcom/google/android/ump/ConsentInformation;

I tried many times but I really have no idea how to solve this error.
Can please someone explain me where is it coming from?


Are you using extensions in your project? I have never seen this class referenced in base App Inventor so I'm not sure that it is coming from us.

Thanks a lot for your very quick reply :slight_smile:
Yes I followed the steps described here:

It may mission this dependency ↓

:question: What does this mean?

Did you build the APK with AI2 and try to install it on your test device. If so, which Android version?
And post a (full) screenshot of the error message.

This is what I get from Google Console.

  • I created the app with AI2
  • I exported the .aab and .apk
  • I uploaded the .aab as internal test
  • I tried to install it on my mobile for testing but I can´t because it immediately crashes

The Android version on my mobile is 7.1.1 .

Ok, so you got this error from the Pre-Launch report (Google Play Developer console).
Did you get this error on all Android versions used in the Pre-Launch report?

So it should say:
"when I uploaded the app (AAB) to the Google Developer Console ..."

Google Play Developer Console reports this error on 8 devices.
I don´t know if it helps:

Ok then this error seems to appear on all Android versions.

Contact the extension developer.