Issues with MIT App Inventor Android App

So I've tried to figure it out how to solve this issues without help but I litterly gave me up. I always getting error message Cannot find the component: MinuteLabel. And then the app crashed. I can't figure out why is keep happening, please help!

My guess is, you copied some blocks from another project?
Fix the red errors. .

There is no red errors, neither yellow errors as well

Post your aia project here, or your relevant blocks with regard to MinuteLabel (note there is no such component by that name)

Here is the screenshot of MinuteLabel that should do

Look though your blocks for any other references to MinuteLabel.

Also worth a look in your designer ?

Here is all my blocks

The only thing I can see is that you set MinuteLabel to "-" in a couple of places, and then you try to carry out a maths operation on MinuteLabel.

Suggest you use a "0" (zero) instead. - a blank textbox is no good, maths blocks cannot handle a blank.

Does this fix it ?

The "-" is settings as no timer. The clock dosen't run

Try this


when MinuteLabel = "-"

That dosen't work. Still the same error

What doesn't work ?

Show a screenshot of this error.

The screenshot you send

  1. Post a screenshot of it.
  2. Post a (small) test aia replicating this error.