Issues building App Inventor sources

Hello Everyone,
I am Dhruv Gupta from India, currently pursuing Btech in computer science. I am interested in Gsoc’20 too. I have been developing applications in java and javascript for the past 2-3 years now and have good knowledge in it.

I tried building app inventor using the quoted document. In the document it is mentioned that Oracle Java 8 is required to build while I have openjdk version 13 installed. When I tried installing Oracle java 8 I found a note that it is no longer available for public download (Stackoverflow’s link) .

I also tried building the app inventor using vagrant as stated in the github readme, but that too resulted in a few errors. I have macOS Mojave. Any help/ guidance is much appreciated.

Also, I would like to know if we could introduce docker, that would really help with such issues.

If we don't know what the errors are, we cannot help you. You may want to start a different thread to discuss the vagrant issues specifically.

JDK's above 11 included usually fail with App Inventor. I found some issues with the components and buildserver.
Even though OracleJDK license changed, you can use OpenJDK 8 or AdoptOpenJDK 8. The 8th version of any JDK will work properly with App Inventor. I use OpenJDK 8 without problems.