Is the Server down?

Every time I try to connect my AI Companion, we can't get past 87%.....tried multiple devices, still no luck.
Anyone Else?

1 Like

That probably means you have a lot of media files or extensions, which might take up large spaces of memory and crash.

1 Like

Try exporting the project as .aia and then tell the file size.

It is a very small file my students are creating, and no media files or entire class is having a problem.

1 Like

Would you like to try connecting your companion in a blank project ?

Also which Companion are you using ?

  • Android
  • iOS
  • Emulator

Apple companion

1 Like

Maybe that's the Problem.

AppInventor has some problems in iOS, as I've known from some posts.

Try using the Android or Emulator Companion then.

IOS has worked all year, just tried my android phone and it worked.
Hoping they fix the apple bug sooon....that is what my students have to use.
Never used the emulator

1 Like

@ewpatton Do you have any ideas about this ?

We are experiencing the same thing...can't get past 87% on apps that have worked before with no issue.

1 Like

I had the same issues with 4 of my students using iPads (Companion) today. I tried with my Android phone and I had no problems. 2 of them have it stuck at 87% and another 2 at 90%. Never happened before and I hope it gets fixed soon.

And yes, with apps that never had any problems before. And small apps, below 100Kb.

Are you also using iOS companion ?

Yes, we are using iOS. The Androids connect fine.

1 Like

Are there any updates for the iOS Companion btw ?

Or  maybe  they've changed something which was not changed for the iOS Companion.

Keyword :  maybe 

Don't take it too seriously.

You should have told us earlier that you are using iOS. :wink: I changed the category.

No issues here to connect with iOS Companion (on a Win7 Prof computer).

Still not working here, students are using windows 10 hp 440s, i am using windows 11 surface pro

ios live development or Android live development?

  • Companion with ios is still probably not working today (at least for some users)
  • live development with Companion for Android works as does building an apk.
  • emulator server is still not working.

Patience while MIT sorts out server issues please. :slight_smile:


The server(s) are completely operational.



If you're in a school environment and are having issues, it is possible the school IT have blocked the computer and iOS device from communicating on TCP port 8001. Do you experience the same issue on Android if you check the "Use Legacy Connection" box in the companion? If so, that supports the port blocking theory. If not, then something else may be going on and we will need to gather more information.