Is the AppInventor CloudDB server down? (now fixed! 1400 GMT 06/01)

[ISSUE RESOLVED] The CloudDB is now up and running as expected.

Hey guys, I'm suddenly getting a Cloud Timeout Error on all my apps.

Error: failed to connect to (port 6381) from / (port 35480) after 20000ms

You might be wondering there's some problem with my blocks/code. But no, the app was working flawlessly - until now. I tried using other apps that I'd previously built using CloudDB on various devices and all of them are showing the same error. So its most probably a server outage. However I just wanted to check if that is actually the case - so can y'all check if your CloudDB apps are working?

1 Like

Confirmed, appears down at the moment


thank you, I was also thinking the same.

The server failed (its network interface went off-line). I rebooted it and it should be working now.


Yes it is working now. Thank you very much!

Hello MIT,

My students and I are experiencing the same issue from Jan 6th above (as shown in the Jan 13th screenshot below). Is it possible that the server failed again and needs a reboot?

CloudDB server working fine @ 8:50 CST (now) for me :slight_smile:

Try again? Works here in Texas.

Still no luck here in Connecticut at 9:58 EST (new screenshot below). This app worked fine in my last school district—is it possible that my new school's firewall, etc. is blocking connections via the necessary port(s)?

Yes. Check with your school's IT department whether .. etc is blocked for ports 6381 and 4392 possibly.

They may need to white list connection url.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.