iOS Translator with emulator in code.appinventor.mit.edu fails

Yandex translator became translator in app inventor environment, its provides new fix and solutions for language such as Arabic, but when test any app compose of translator component the following error message appears:


Note: the app work properly with AI Companion.

Hello Mohammad

Good news that your App works with the Companion. I wouldn't expect it to work in the current Emulator, which is really at it's best for testing and proving small snippets of code.

Later this year, we should see an Emulator upgrade which will help those that do not have a physical device to test on but Companion (and built APK) will always be the best way to test.

1 Like

thanks for replay,
the problem that I phase the AI Companion work for android devices but not for iPhone devices.
I work in a university computer lab, all students have smart phone but a lot of them have iPhone.
the iPhone will not work with AI Companion but android are.
If you provide a solution for this problem i would appreciate it.

Hi Mohammad

You didn't mention you are using iOS :upside_down_face:

Since at least 99% of the Forum Topics are about Android, it's very important to state that your Topic is about iOS.

Testing on AI Companion done by using android device.

But the reason we using the emulator that the AI Companion is not working for iOS for the lab.
Note: the lab composing of 30 desktop device connect to the internet through wire network.

Hi Mohammad

Can you post the:
PC: OS + version;
PC: Browser Name + version;
Smartphone: OS + version.

This will help the MIT developers.

Can you also try http://ai2.appinventor.mit.edu - if your project is too big for that Server (>30mb), just try a simple Project running only Translator.

Finally, what were the languages you tried to translate from - to?

I tried Arabic (ar) and English(en) in the yendex the Arabic language was each letter was separate but has been fixed in the translator's new version.
The app-only composes a few blocks.
I will provide the other information tomorrow when I arrive at work.

1 Like

the operating system is windows 10(windows 10 enterprise)
the browser was (brave and chrome) work the same for both.
the phone was Samsung A53
ai2 link is not working