Invoke: no method named `ShowTextDialog' in class java.lang.Boolean

i already wrote the coding exactly like my teacher's and every time i tried to connect to the emulator it keep telling me "invoke: no method named 'ShowTextDialog' in class java.lang.Boolean and i couldnt connect to the emulator

Welcome maple

Do your other Projects load into the emulator OK? Or, are you only having a problem with this one? We would like to help, however you need to provide more information maple (we need to see the code that is not working).

There are many possibilities for getting an error message like this. Some code cannot run in the emulator.

If you post an image of the code blocks 'exactly like my teacher's' someone probably can provide a recommendation and help.

this is my first time so i didnt write any project before and this is the code block

Code Block

That does not happen when I run this code in the emulator that comes with App Inventor maple. The emulator displays as shown.

zooHoo2
When I type my name and press OK as shown above; this displays

zooHoo3 because I told the program to place what is entered when you enter your name in the Button caption.

You might rename the global variable name to theName and try again and see if the emulator loads. Does it load without the error?

If it does not, try loading the attached aia file testingMaple.aia (2.1 KB) . Does this example load?

Does this help?

which version of the companion app is running in the emulator?
probably you need an update?
see also the FAQ


Taifun


Trying to push the limits! Snippets, Tutorials and Extensions from Pura Vida Apps by Taifun.

i tired changing "name" to "theName" and it still doesn't work. Also, I couldn't open the file attached.

it's working now after the update. thank you!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.