Invoke: no method named `............' in class java.lang.Boolean

Hi all!

My problem with this subject began yesterday morning. Two days ago I was working on my app and till end of the day everything was ok. Yesterday after very small modifications (irrelevant) I tried the companion and got this error with "Clear all" note. In the Screen1.Initialize I got the block "TinyDB.ClearAll" so I disabled this block.


This moved the issue to the next block with callASD from TaifunFile Extension. Same error. I made some more block disabling, but after the 5-6th block I gave up.

I checked on another app with companion and got "Cannot find the component: etyk_ver" (the component is present!)
After disabling some "Cannot find the component: ...." errors, I got again the "invoke:.....Boolean".

Is there some major problem with App Inventor or is it just me.

I reinstalled the companion app. I tried on an other android device... Nothing helped.

I've deleted the "clock" which was not even in the blocks present...and it works... Maybe it helps someone.

Thanks for sharing.
Probably the same result would have been obtained unticking at design level "clock always fires" and "clock enabled".
Although, for sure, "dead (unused) code" shall be always removed :slight_smile:
Cheers !

Hi All,

the problem is again present. There is no clock in the app, so it's not the situation... Can anyone help please?

I get the error on the start of the app.

When i disable the "ClearAll" block, I get the same error from the next one...

I tried to compile it, but get something like that:

Does it mean there is something with the extension?

I was playing a bit with the extensions "de.bodymindpower.DownloadToASD.aix" and I thing there is something with there.

@Anke Could you please help me here?

...any feedback?

are there any red warnings in your project?
if yes, fix them before compiling
in case this does not help, remove the extension and try to build again
you might want to backup your project previously...


Hi Taifun,

there were currently two red warnings...probably done them during the testing process. I've corrected them and error still there.

I've changed the version of the extension to a "hidden notifications" version. This gives another error, but this lets me work further:

Nonetheless, thanks for the feedback.


What's that? Always use the latest version of an extension and show a screenshot of your relevant blocks


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.