Internal Error has Occurred, Report a Bug?

I've been using this application on this computer the entire year and for the last few days, anytime I try to open up any of my past applications, It states " An internal error has occurred. Report a bug?" I've done so, restarted my computer and tried multiple times to no success. Is there anything else I can do or someone I can contact?

If you send me a private message with the server you are using, your account name, and the project name we can have someone on our team take a look.

Unfortunately, none of the projects are opening up and I'm not even allowed to open a new one.

This link should take you to your Project List, where you should be able to check mark a Project and export it to .aia without opening it.

MIT App Inventor

It sounds like you are in imminent need of external backups.

I'm still having the same issues, can anyone help. I've been using Google Chrome and we've been using

  • you use the main server link. Do you can see your Projects displayed. If so exactly what happens when you click on a Project?

  • are you using an emulator or a device (which Android version?)

  • are you using extensions?

  • are you using Companion 2.66?

  • have you tried using Firefox

Whenever I try to click any project, a pop up comes up saying "An Internal Error has occured. Report a bug?" And I have reported it. I tried using the application on Microsoft Edge for the same thing to happen as well.
When we use the application I have the students download their files to a tablet but I never connect mine. (which is the computer not working, their's work)
I'm not entirely sure what Companion 2.66 is

  • you are using a school network
  • students can connect to Projects with no problems. You the teacher can not. It is possible teachers have a separate network at your school. The student tablets are not blocked but your access is possibly blocked. I do not know.. Discuss this with your IT department. Try this check; take your tablet and use it on your home network. Do the Projects load? If they do load, you may have a different network than your students.
  • Another thing to try: Create a new Project. Are you able to do that? Just add a Button to the Designer, then use Companion to load the Project. When you load, do you see a Button on your tablet?
  • there could be other issues

See Connect your Phone or Tablet over WiFi . It is possible you do not have the updated version of Companion. This, in it self should not prevent you from loading Projects but may cause other issues depending on the coding. You need to use 2.66 or 2.66u.

I just had IT take a long and they turned off the pop up blocker for the site but I am unable to really do anything on the site, including creating a new project and then opening it.

The same is happening with my co-worker's username
IT stated that The error has to do with a 'circle' object that cannot be found. and that he believes that it is user name based.

This document may help your IT people get you and your colleague up and running as per you description is an issue with some teacher's privileges on the network.

Can you send me the email address you use to login to ai2 (you can e-mail it directly to and if possible a screen shot of the error. I can then look into it.



So working with Brent and his IT folks, the problem was determined to be a firewall issue, and is now solved.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.