Installation appinventor in ubuntu


I have Ubuntu mate 18.4 64 bits, I run appinventor setup .deb, but is no posible install it, I tried with Gdebi and terminal. I use: sudo apt install lib32z1, sudo dpkg --install " appinventor package. I tried with sudo dpkg --add-architecture i386, sudo dpkg --configure -a and sudo apt -f install, but is no posibe.
How can install appinventor in ubuntu?

PD: maybe is a good idea make flatpak or snap for linux.

Best regard.

App Inventor is not distributed as a package in any package manager or store. If you want to install it, you need the current sources: GitHub - mit-cml/appinventor-sources: MIT App Inventor Public Open Source
And I say install because it does not get installed. You run App Inventor, not install it (as there are no binaries or "generic" compiled executable),

1 Like


Thank for your answer. I don’t understand, you say that there is’nt package of appinventor, but in this official link there is a deb package:

Best regards.

Those instructions are for installing the emulator on Linux systems. Perhaps the @MIT-App-Inventor team would want to change the page title to include this clarification so that users (like the OP in this case) aren’t directed to the emulator setup page from a search engine

OK, I understand.

Thank you so much.