Install an APK after downloading to ASD - works on all Android versions

I'm sorry, but I did not understand

Read the whole thread and you will understand.

Thanks for the help, I give up

Where is the problem in renaming the APK from e.g.
myApp.apk to
in Google Drive and then download this file (as shown in my link)?

sorry, I'm also confused...
@Anke are you saying, your solution is only able to download png files?

I tried to download a real image with your block, the image were downloaded but it is corrupted

Post the aia or send it to me via PM.

This is the aia
Instalacion_3.aia (25.8 KB)

with companion I can download the apk, the size is correct, but I can not install it by companion, building produces this error:

Try this one:

Your apk runs well, but where is the issue ? My aia was correct?


Obviously not. So create a new project with my blocks and try again.

Why not correct ? I used your aia in post 78, I don't see any substantial differences between the 2 projects, anyway a new project runs well.

Fine, then something went wrong with your (old) project.

In my opinion you should clarify well in the first post that it is necessary to insert a png renamed apk on gdrive

1 Like

This has nothing to do with my extension. It's an issue with Google Drive.

You are right, but this note would save you a lot of answers

1 Like

Hey @Anke,

Thanks for this great extension!
It works flawlessly on my Samsung Galaxy A30s - Android 11 (without any READ/WRITE permissions)

However, when I try to use it on my Samsung Galaxy J Max - Android 5.1.1, it throws up this error:

I tried asking for READ EXTERNAL STORAGE and WRITE EXTERNAL STORAGE on Screen Initialize but the problem still persists.

Additionally, I tried asking for android.permission.REQUEST_INSTALL_PACKAGES" but the problem still exists.

I tried searching and I might have overlooked something in this lengthy thread, but can you let me know why this is happening and how to resolve this?


Post the aia (and also the blocks).


The app extension has been changed to .png before uploading to Google Drive as mentioned.

Working great on Android 11, but throws an error on Android 5.1.1

APK_Downloader_Test.aia (14.3 KB)