Install an APK after downloading to ASD - works on all Android versions

Dear Anke,
I'm a young novice student, sorry but it's my first time on this platform and I got a problem with the version 3 of the extension.
I can download the apk but it shows an error, and even if I can find the downloaded apk, I see that also the file's size is wrong so I can't open it.
I've already read similar problems in this community and checked e.g. I linked a file and not a folder..
but I don't know how to make it works.
I share the error screen and my blocks.
Thank you in advance

Did you rename the APK to <yourApk>.png before uploading to Google Drive?

As shown here:

Try this:


Yes, I've already tried all of them but I've always the same error.
So, if I disable the block with the installation, I don't have any problem downloading the apk and I can complete it, but even if I click on the "Instalar" button, I have the same error.
I think the problem consists in this part of the program, do you have any suggestions?
Hope I was clear

@Claudio_Demaria Try this one:

If it doesn't work for you, which device & Android version?

Please excuse the delay, but finally this apk works! I mean the "installAPK_AI2.apk"..
Can I see the blocks? Thank you very much!

I just updated the extension to version 6 (added two new blocks):

1 Like

I've downloaded the version 6, and now I have this problem.. It can't build the apk

Post the aia.

Instalacion.aia (25.8 KB)

I opened your aia and got this:

Please ... :pray:

Your url is also wrong. So PLEASE check it before posting. :pray: