Inserted image not showing

Please help. I’m having difficulties inserting images. I’ve followed all the necessary steps; my image is less than 300K and in jpg format. The image uploaded alright but upon inserting it just shows the icon for the image but no picture, even preview not showing.

Please show any relevant blocks and designer screenshot

Just within designer

I am not able to replicate your problem. I started a new project and was able to successfully upload png and jpg image files to the project and view them in an image component.

Are you seeing any error messages ?

Have you tried any other images ?

No error message, just that cut image icon showing image is inserted but can’t display. Yes, I’ve tried a number of images all not displaying. I don’t just know what the problem is.

Does the filename of the image contain spaces?

No. It doesn’t have any spaces

Can you share your aia project? This will allow others to test (is it in the project, is it AI2, etc.)

you can rename the JPG file I was also facing same issue so i thought to rename the JPG file and i renamed it and uploaded and it was showing the preview and was also inserted in button and image tool
you can try this

i have the same issue and i am just starting a new project, after i upload the image that contains

size 130kb

format jpg

file name iii that has no space

I’ cant see the uploaded image in the screen only the image icon , but in the media window I can preview the image

How can I resolve this problem ? thanks

You do not show your blocks, however, you have not set the image file to the image component in the designer ?


1 Like

I'm also having the exact same issue. The app should change the image using the blocks, not set in the properties.

The app will crash when I open the location page. It has something to do with the images as it will load the screen when the images are not being called. With one image in the list, the location screen will load but the image will not show up. These images are all under 60kb file sizes, 200 pixel widths set in Photoshop.

brentonPoint firstBeach fortAdams secondBeach TourGuide_template.aia (153.8 KB)

Change this:


to this:


the image component cannot load a list....


Thank you.

I've had that same problem, and I've found out the issue for me. The issue happens when I press save as, and then check if your name to the file your downloading is something like "Image(1)" and change it to a different name that you have not named any other file on that device.

Hope this helps!

wait a sec, do you mean that renaming an image file will make it show? I'm facing the same problem right now, but its showing in designer but not in the live test...


Try renaming the image. Do not use signs and letters of a language other than English