Incorrect Thumb Position setting

I run the following Application, I type 15 in to the text box, click Set Scroll Value and the slider actually reports a value of 14.8
SliderBug.aia (3.3 KB)

where is the textbox? :rofl: :rofl: :rofl:

the given aia does not have a text box

That's all a bit strange, try this one. I moved the text entry field in to a horizontal layout.

ScrollBarBug.aia (1.9 KB)

Try this one:
ScrollBarBug_2.aia (2.0 KB)

:joy: :joy: :joy:

1 Like

LOL! I need to check this as it's still not working for me :wink:

1 Like

I thought I was losing my mind......OK, the error shows up when the Max for the scroll bar is 30, check this out.

ScrollBarBugMax30.aia (1.9 KB)

Enter 4 and the value says 3.9

Screenshot from 2023-10-03 18-26-24

Have you tried this



The issue there is that I then loose my none-integer values using the slider.


On the following Graph EntryClick on any points, for instance Point 2 which is at (2000,4), note the X-Axis says 1999.9999, Look at X=2000 and Y=4 then look at the scrollbar value it's 3.9 it should be 4.

SliderBug.aia (3.3 KB)

Click on the same point again and it is correct! The first click always seems wrong.

I notice if you set the MaxValue of the ScrollBar to 50 it works OK. It seems to work OK with Max Values of 5, 10, 20, 100 but not 30.

hello Youngie!
please don't ask a question many times to keep our community clean of unrelated or available (asked) topics
@moderators please move this topic to:

1 Like

If you enter 4 TWICE it works the second time!


ScrollBarBugMax30 (1).aia (2.1 KB)

I solved it a slightly different way! If you call the function twice it sets the correct value.

this does ot make sense to me