Import filtered data from app script

Hello everyone, I start with java programming, I created a script to filter a database on google spreadsheet by making collages from different tutorials found on the internet.

This is my script:

The script works and produces an array with the data I'm interested in, but when I call the script from App Inventor I can't transform it into a list of list but it remains a text string separated by commas.

This is my bloks:

This is the output:

Another step that I can't get rid of is displaying the html data that appears before the data I'm interested in.

This is the first screen:

I can't figure out which step is missing or wrong to avoid receiving the html text and to have the data to be transformed into a list with the list from csv table function.

Thanks in advance

(P.S. Sorry for my english traslate with google)

  1. Remove the "Web1.GET" block
  2. Convert your responseContent to an AI2 list with the "list from CSV row" or "list from CSV table" block

Thank you very much TIMAI2, htlm text is now solved, but "list from CSV row" or "list from CSV table" block don't work.
I've already "Cannot parse text argument to "list from csv row" as CSV-formatted row" or "Cannot parse text argument to "list from csv table" as CSV-formatted row" error.
The output text looks fine, it's a multidimensional array (list in list), but when I import it, AI2 read it like a comma separated text.
It seems to me that the \n tab is missing.
I'm doing it wrong?

Possibly the data is coming back as a stringified JSON array. Use the JsonTextDecode block from the Web component instead?

I'Ve tried, but i've a error too, in this week end i send screenshot.

Thanks for your time and help.

Try this in your script

return ContentService.createTextOutput(JSON.stringify(elenco));

and this in your blocks