If I use 2 ListView, I have a bug

I have a problem with two ListView.
If I click on one element of the second ListView it gives me the good result.
If I click on one element of the first ListView it gives me the result of the second ListView.
All my projects have this problem since August.


Yes, this is a big in the new release. Wait for the bug to be fixed.

1 Like

Does anyone know when this will be fixed?

I'm wondering if the new version of the list view was tested thoroughly before putting in production...
I hope the fix will be there soon.

Ask @ewpatton. The reason of there is so many bugs with ListView is because ListView has added many new features.

1 Like

The new list view was available on the test server and anyone could test it. There were no reports that something was not working, so it was considered to be working.

1 Like

Hi Patryk, I didn't know that. Where are such things announced?
Hopefully the fix will be there soon.


Try ai2-test.appinventor.mit.edu, the server used to test MIT App Inventor.

1 Like

I mean where is it announced that important functionality like listview is going to be updated and can be tested on the testserver?

We are looking at creating a bug tracker category where these things are updated.


I tied using Test server, I copied my aia project from nb187 to my projects on test server and complied (built apk) but I still see the issue with nb188 test version.

Question: Should I do something different like build my app completely in NB188 version?


  1. If 2 or more list views have same number of elements, its not crashing, but selection is still having bug.
  2. If list 1 has 5 elements, and list 2 has only 2 elements, and if I select 4th element from List 1 since 4th element is not present in List 2 the app crashes.

It seems the selection (Filter) procedure is having issue, because if I keep same number of elements at least the app is not crashing.


I tried it on the testserver and the problem is fixed there :slight_smile:
"afterpicking" is triggering the correct listview.

I have same amount of items in 3 listviews, so I can't test the issue Rajesh is having.


UPDATE: Oct 3rd
My bad, - the test server build is working properly. By mistake I was still checking my old build and the new build did not get installed the first time, :man_facepalming:
After installing the new build from test server it worked as expected.