I used private CloudDB,but it happened some error: java.net.SocketException

Please help me!

Try untick the SSL checkbox (if you haven’t setup SSL)

Before I asked the question,I unticked the SSL checkbox.But it still like this.I did as the teacher told me,but the results were different.So I tried to ask her and she gave me some advice, but it didn’t work.

Check your server url, port number and your token (secret password in redis)…

How is it setup and where is your private cloudDB - on the internet or local server?

I’ve noticed that too, and my teacher told me the same thing.

She emphadized what you said, and I did.

But what I did were different from what she did. So I’m confused.

For some reason,she couldn’t share with me what she did from beginning to end. I can share what she shares with me.And could you help me seek the problem? I looked up a lot of data but couldn’t find a solution.

Thank you for your previous help.

Is it working now ?

Just like before.

Yes, the same is happening with me, the server works when I am on my AI2 Companion but when I download it on the same device, the cloud service doesn't work.


The default MIT CloudDB works fine here when using either Companion or compiled. (I just tried both using an Android 8.1) and the MIT CloudDB is working correctly.

Possibly you have a problem with your Blocks (which you have not shared), an issue with your Android version.

What does doesn't work mean? The default MIT CloudDB is currently working fine. Perhaps try again. Are you getting error messages or what? If so, please share them.

The cloud service doesn't work when compiled, but works perfectly with companion.